Meters and Connections

Moving or need advice about your digital, net or gross meter? Ask your question here.

Moving or need advice about your digital, net or gross meter? Ask your question here.

Smart meter EDMI Atlas Mk7c

Ted
Switched-on

I have been struggling since about 20 Feb to get my feed in data to be reliably shown on my account's usage page. I am satisfied that that has now been fixed, and for that I am grateful. However in my efforts to research that problem I have discovered that on my EDMI Mk7c the 2 lights more or less in the middle of the front are shown as "1000 Imp/Kwh" on the left, and "connection state" on the right whereas on your picture of the Mk7c the lights are shown as (I think) Pulse 1 and Pulse 2. I realize that in normal circumstances those lights really shouldn't concern me except that the light labelled connection state is illuminated RED all the time and to me a red light means something is wrong!!

Any comments on why my unit is different to the pictures in the AGL article and why the connection state light is always illuminated RED.

3 REPLIES 3

Re: Smart meter EDMI Atlas Mk7c

Switched-on

Ted, I have just had a smart meter installed (6 March) and have a continual red light under “Connection State”.    Hopefully someone can explain this as I have found no documentation to explain if this is normal or it is advising there is a fault.

 

Re: Smart meter EDMI Atlas Mk7c

Ted
Switched-on

If you are getting accurate & reliable readings at MY ACCOUNT / USAGE on your AGL website then I reckon the red light must be the way it should be. It would be nice if someone at AGL would acknowledge our concerns.

 

Regards

Re: Smart meter EDMI Atlas Mk7c

Switched-on

Yes, I am getting accurate readings now, so red light must be normal for this new type of meter.